Search
▫️

Menu bar

Index
1.
Installation
3.
Basic components

Objective

Menu Bar includes essential menu for using z-weave such as file, environment.

Component

File

On File menu, users can open/save ZLS format and import/export specific format.
New
New is a function to create new workspace
Open
Open is a function to open ZLS format files you saved or downloaded.
Append
Append is a function to open another ZLS file additionally while keeping the ZLS file you are working on.
Save
Save is a function to save working data as ZLS file.
Save As
Save As is a function to save working data as ZLS file with another name.
Import
Import is a function to open the other formats such as DXF/ZCAM not ZLS format.
Export
Export is a function to save the other formats such as DXF/ OBJ/ glTF/ ZCAM not ZLS format.
Recent Files
Recent Files is a function to show a ZLS list recently opened.
Exit
Exit is a function to terminate the z-weave program.

Edit

On Edit menu, users can operate various function such as Undo/Redo, Pin/Tack.
Undo/Redo
Undo/Redo is a function to undo and redo actions.
Tack
Tack is a function to attach a point on a Surface to a point on a Surface or Avatar.
Pin
Pin is a function to fix a point on the Surface to the position when the Pin was added in 3D View space.
Quick Move
Quick Move is arrangement function in 3D View by to attach two point on a Surface to two point on a Avatar.
Fabric Placer
Fabric Placer is a function to change the direction of Texture, Weft/Warp on a Surface.

View

On View menu, users can operate Gizmo control, Image Saving Option control.
Gizmo
World Gizmo
World Gizmo is created based on the X/Y/X axis of 3D View space.
Local Gizmo
Local Gizmo is created based on the X/Y/X axis of selected object.
HQ Render
HQ Render is a function that to create high quality of image.
Image Capture
Image Capture is a function that to save the image shown in 3D View.
Normal
Normal is an option to show front direction of Fabric.

Simulation

On Simulation menu, users can control Simulation actions.
Start/Pause
Start/Pause is a function to run and stop simulation.
Step
Step is a function that run simulation frame by frame.
Reset
Reset is a function to reset simulation state to arrangement state.

Window

On Window menu, users can control Toolbar and Window.
UI Panels
UI Panels is an option to show or hide entire UI Panel on the z-weave window.
Colorway / Draping Board / Rendering / Simulation / Avatar / Fabric / Properties / Camera Preset
It is an option to show or hide specific UI Panel
Detail View
Detail View is an option to show or hide Preview image shown when hover Fabric/Avatar icon.
Font Size
Font Size is an option to set the Font size of z-weave Window.
Language
Language is an option to select program language.
For now, z-weave supports English, Spanish, Chinese (Simplified/Traditional), Japanese, Portuguese.
Reset Layout
Reset Layout is a function to restore z-weave window layout as default.

Help

On Help menu, users can make operation on version information and account.
About
About is a function to check z-weave version infomation.
Logout
Logout is a function to sign out z-weave.
Just after executing Logout, z-weave window will terminate and Login message box will appear.